Intermittent DNS Resolution issues

Incident Report for Cluvio

Resolved

This incident has been resolved.
Posted Feb 11, 2026 - 10:03 CET

Update

The issue has been resolved by AWS.
Posted Feb 11, 2026 - 10:01 CET

Monitoring

From out server logs we observe only a small fraction of users being impacted.

AWS just provided an update on the issue recovery:

Feb 10 1:58 PM PST We can confirm significant recovery for the DNS resolution errors for Cloudfront distributions. Customers are still experiencing delays propagating changes to Cloudfront distributions. We continue to work toward full recovery and will provide additional information in the next 30-60 minutes.
Posted Feb 10, 2026 - 23:02 CET

Identified

We are tracking intermittent issues accessing Cluvio web app and embeds, showing DNS resolution errors.
The root cause seems to be ongoing AWS Route53 issue: https://health.aws.amazon.com/health/status

We continue to monitor the situation, the impact so far seems to be limited and intermittent.
Posted Feb 10, 2026 - 22:51 CET
This incident affected: EU (Germany, AWS eu-central-1) (Cluvio Web Application (EU)) and US (Oregon, AWS us-west-2) (Cluvio Web Application (US)).